all repos — ports @ 2e5c77dedef64774b047d9e1e0a3480601e803aa

collection of ports for openbsd

net/matterbridge/Makefile (view raw)

 1COMMENT =		bridge between multiple chat platforms
 2
 3VERSION =		1.26.0
 4REVISION =		0
 5
 6DISTNAME =		matterbridge-${VERSION}
 7
 8GH_ACCOUNT =		42wim
 9GH_PROJECT =		matterbridge
10GH_TAGNAME =		v${VERSION}
11
12CATEGORIES =		net
13
14HOMEPAGE =		https://github.com/42wim/matterbridge
15
16MAINTAINER =		la ninpre <aaoth@aaoth.xyz>
17
18!# Apache-2.0
19PERMIT_PACKAGE =	Yes
20
21WANTLIB +=		c pthread
22
23MODULES =		lang/go
24MODGO_FLAGS =		-tags nomsteams # don't need to build that cr..., ahem, big thing
25
26ALL_TARGET =		github.com/42wim/matterbridge
27
28do-install:
29	${MODGO_INSTALL_TARGET}
30	${INSTALL_DATA_DIR} ${PREFIX}/share/matterbridge
31.for _c in sample simple
32	cp -Rp ${WRKSRC}/matterbridge.toml.${_c} ${PREFIX}/share/matterbridge/matterbridge-${_c}.toml
33.endfor
34
35.include <bsd.port.mk>