media-libs/libaudec/libaudec-0.3.4.ebuild (view raw)
1# Copyright 1999-2022 Gentoo Authors
2# Distributed under the terms of the GNU General Public License v2
3
4EAPI=8
5
6inherit meson
7
8DESCRIPTION="library for reading and resampling audio files"
9
10HOMEPAGE="https://git.zrythm.org/zrythm/libaudec/"
11
12SRC_URI="https://git.zrythm.org/zrythm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14S="${WORKDIR}/${PN}"
15
16LICENSE="AGPL-3+"
17
18SLOT="0"
19
20KEYWORDS="~amd64"
21
22IUSE="test"
23
24RESTRICT="!test? ( test )"
25
26RDEPEND=">=media-libs/libsamplerate-0.1.8
27>=media-libs/libsndfile-1.0.25"
28
29DEPEND="${RDEPEND}"
30
31BDEPEND="dev-util/meson
32dev-util/cmake"
33
34src_configure() {
35 local emesonargs=(
36 $(meson_use test tests)
37 )
38 meson_src_configure
39}