all repos — la-ninpre-overlay @ 9782d196fc9e433ab3dc5341f2ce6253630c2e99

personal gentoo overlay

net-im/gajim/gajim-1.7.1.ebuild (view raw)

 1# Copyright 1999-2022 Gentoo Authors
 2# Distributed under the terms of the GNU General Public License v2
 3
 4EAPI=8
 5
 6PYTHON_COMPAT=( python3_{9,10} )
 7PYTHON_REQ_USE="sqlite,xml"
 8DISTUTILS_SINGLE_IMPL=1
 9DISTUTILS_USE_PEP517=standalone
10
11inherit distutils-r1 xdg-utils
12
13DESCRIPTION="Jabber client written in PyGTK"
14HOMEPAGE="https://gajim.org/"
15SRC_URI="https://gajim.org/downloads/$(ver_cut 1-2)/${P/_p/-}.tar.gz"
16
17LICENSE="GPL-3"
18SLOT="0"
19KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
20IUSE="+crypt geolocation jingle omemo remote rst +spell upnp +webp"
21S="${WORKDIR}/${P%_p2}"
22
23COMMON_DEPEND="
24	dev-libs/gobject-introspection[cairo(+)]
25	>=x11-libs/gtk+-3.22:3[introspection]
26	x11-libs/gtksourceview:4"
27DEPEND="${COMMON_DEPEND}
28	app-arch/unzip
29	virtual/pkgconfig
30	>=sys-devel/gettext-0.17-r1"
31RDEPEND="${COMMON_DEPEND}
32	$(python_gen_cond_dep '
33		dev-python/idna[${PYTHON_USEDEP}]
34		>=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
35		dev-python/pyasn1[${PYTHON_USEDEP}]
36		>=dev-python/pycairo-1.16.0[${PYTHON_USEDEP}]
37		dev-python/pycurl[${PYTHON_USEDEP}]
38		dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
39		dev-python/pyopenssl[${PYTHON_USEDEP}]
40		>=dev-python/nbxmpp-4.2.0[${PYTHON_USEDEP}]
41		<dev-python/nbxmpp-5.0.0[${PYTHON_USEDEP}]
42		x11-libs/libXScrnSaver
43		app-crypt/libsecret[crypt,introspection]
44		dev-python/keyring[${PYTHON_USEDEP}]
45		>=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
46		dev-python/css-parser[${PYTHON_USEDEP}]
47		dev-python/packaging[${PYTHON_USEDEP}]
48		net-libs/libsoup[introspection]
49		media-libs/gsound[introspection]
50		crypt? (
51			dev-python/pycryptodome[${PYTHON_USEDEP}]
52			>=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
53		geolocation? ( app-misc/geoclue[introspection] )
54		jingle? (
55			net-libs/farstream:0.2[introspection]
56			media-libs/gstreamer:1.0[introspection]
57			media-libs/gst-plugins-base:1.0[introspection]
58			media-libs/gst-plugins-ugly:1.0
59			media-plugins/gst-plugins-gtk
60		)
61		omemo? (
62			dev-python/python-axolotl[${PYTHON_USEDEP}]
63			dev-python/qrcode[${PYTHON_USEDEP}]
64			>=dev-python/cryptography-3.4.8[${PYTHON_USEDEP}]
65		)
66		remote? (
67			>=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
68			sys-apps/dbus[X]
69		)
70		rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
71		spell? (
72			app-text/gspell[introspection]
73			app-text/hunspell
74		)
75		upnp? ( net-libs/gupnp-igd[introspection] )
76		webp? ( dev-python/pillow[${PYTHON_USEDEP}] )
77	')"
78
79src_install() {
80	distutils-r1_src_install
81
82	# avoid precompressed man pages
83	rm -r "${D}/usr/share/man"
84	doman data/*.1
85}
86
87pkg_postinst() {
88	xdg_icon_cache_update
89	xdg_desktop_database_update
90}
91
92pkg_postrm() {
93	xdg_icon_cache_update
94	xdg_desktop_database_update
95}
96
97# Tests are unfortunately regularly broken
98RESTRICT="test"