dev-libs/libcyaml/libcyaml-1.3.1.ebuild (view raw)
1# Copyright 1999-2022 Gentoo Authors
2# Distributed under the terms of the GNU General Public License v2
3
4EAPI=8
5
6DESCRIPTION="C library for reading and writing YAML"
7
8HOMEPAGE="https://github.com/tlsa/libcyaml/"
9
10SRC_URI="https://github.com/tlsa/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
11
12LICENSE="ISC"
13
14SLOT="0"
15
16KEYWORDS="~amd64"
17
18IUSE="debug"
19
20RDEPEND="dev-libs/libyaml"
21
22DEPEND="${RDEPEND}"
23
24BDEPEND="virtual/pkgconfig"
25
26src_configure() {
27 if use debug ; then
28 VARIANT=debug
29 else
30 VARIANT=release
31 fi
32
33 export VARIANT
34 export PREFIX="${EPREFIX}/usr"
35 export LIBDIR="$(get_libdir)"
36}