all repos — la-ninpre-overlay @ 7e17209d16e2e8176356bddb6efb496495ee929c

personal gentoo overlay

media-libs/lsp-dsp-lib/lsp-dsp-lib-1.0.7.ebuild (view raw)

 1# Copyright 1999-2022 Gentoo Authors
 2# Distributed under the terms of the GNU General Public License v2
 3
 4EAPI=8
 5
 6DESCRIPTION="DSP library for signal processing"
 7
 8HOMEPAGE="https://github.com/lsp-plugins/lsp-dsp-lib"
 9
10LSP_COMMON_LIB_PV="1.0.21"
11LSP_TEST_FW_PV="1.0.15"
12SRC_URI="
13	https://github.com/lsp-plugins/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
14	https://github.com/lsp-plugins/lsp-common-lib/archive/refs/tags/${LSP_COMMON_LIB_PV}.tar.gz -> lsp-common-lib-${LSP_COMMON_LIB_PV}.tar.gz
15	https://github.com/lsp-plugins/lsp-test-fw/archive/refs/tags/${LSP_TEST_FW_PV}.tar.gz -> lsp-test-fw-${LSP_TEST_FW_PV}.tar.gz
16"
17
18LICENSE="LGPL-3+"
19
20SLOT="0"
21
22KEYWORDS="~amd64"
23
24IUSE=""
25
26src_unpack() {
27	default
28	mkdir "${S}/modules"
29	mv "${WORKDIR}/lsp-common-lib-${LSP_COMMON_LIB_PV}" "${S}/modules/lsp-common-lib"
30	mv "${WORKDIR}/lsp-test-fw-${LSP_TEST_FW_PV}" "${S}/modules/lsp-test-fw"
31}
32
33src_configure() {
34	emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" config
35}