all repos — la-ninpre-overlay @ 1d48072f5d0db8936c42622190ace5bb1c6b7221

personal gentoo overlay

gui-libs/libpanel/libpanel-1.0_alpha1.ebuild (view raw)

 1# Copyright 1999-2022 Gentoo Authors
 2# Distributed under the terms of the GNU General Public License v2
 3
 4EAPI=8
 5
 6inherit meson
 7
 8DESCRIPTION="dock/panel library for GTK 4"
 9
10HOMEPAGE="https://gitlab.gnome.org/GNOME/libpanel"
11
12MYPV="1.0.alpha1"
13SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${MYPV}/${PN}-${MYPV}.tar.gz -> ${P}.tar.gz"
14
15S="${WORKDIR}/${PN}-${MYPV}"
16
17LICENSE="LGPL-3"
18
19SLOT="0"
20
21KEYWORDS="~amd64"
22
23IUSE="vala introspection examples"
24
25RDEPEND=">=dev-libs/glib-2.72
26>=gui-libs/gtk-4.6
27>=gui-libs/libadwaita-1.0
28vala? ( dev-lang/vala )
29introspection? ( dev-libs/gobject-introspection )"
30
31DEPEND="${RDEPEND}"
32
33BDEPEND="virtual/pkgconfig
34dev-util/cmake
35>=dev-util/meson-0.60"
36
37PATCHES=(
38	# i know this is stupid but whatever
39	"${FILESDIR}/${P}-gtk4.6.patch"
40)
41
42src_configure() {
43	local emesonargs=(
44		$(meson_use vala vapi)
45		$(meson_feature introspection)
46		$(meson_use examples install-examples)
47	)
48	meson_src_configure
49}